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LAB EXERCISE 1 

ADS Layout Basics 

                  
 

Topics:  Settings and drawing tools in the layout window that apply to both board 
and MMIC designers. 

Audience:  Engineers who have a basic working knowledge of ADS, have 
completed the prerequisite course, or who required layout training. 

Prerequisites:  Completion of the course, Workspaces and Simulation Tools or 
equivalent experience, including basic circuit design concepts.    

Objectives: Be able to set layout preferences and technology and use basic 
drawing features and commands for board or IC design. 
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 Lab 1: Layout Basics  
 

IMPORTANT: This lab covers the basics of the layout window, drawing shapes, 
and the layer technology – and it assumes ADS 2012 is running on your computer 
or you have access to it.  Also, you must be able to use the ADS 2012 Workspace 
environment for basic applications. 

1. Create a New Workspace  

a. IN the ADS Main window, use the wizard to create a new workspace:  File > 
New > Workspace or use the icon.  Name the workspace: My_Layout_1_wrk 
- click Next. Then add only the Analog/RF library as shown here – click Next. 

 

b. Use the same name for the workspace library (My_Layout_1) and keep the 
default technology: Standard ADS Layers as shown here – these layers are 
built-in to ADS and you will see them in the layout window soon - click Next. 

 

c. Click the Finish button and your Main window 
should now show the new workspace – ready 
for the next steps !. 
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2. Create a cell / layout and view docking windows 

a. From the Main window, create a new layout, using the 
default cell name: cell_1, as shown here.  Immediately, 
the layout window will appear.  

 

b. In the layout window,  (see the picture here):  

1. Use your cursor and click on the arrow button to view the layer list – 
these are the built-in ADS standard layers and cond is the active entry 
layer – it is both V (visible) and S (selectable). 

2. With cond as the active entry layer, click on the Insert Rectangle icon. 

3. Left-click your cursor to draw a rectangle – notice the delta X-Y 
information as you draw it – then click to stop the drawing.  To 
end the command, either click the icon (shown here) or click in 
an open area of the layout. 

4. Select the rectangle you drew and notice that the properties now 
appear on the right of the window – this is how you can easily identify 
all the properties of shapes, traces, paths, and artwork.  Click in an 
open area to deselect the rectangle or use the End Command icon. 
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3. Technology Setup  and drawing layers 

a. In the Main window, click Options > Technology > Technology Setup.  

b. The Layout Units tab shows the basic layout units and resolution that should 
not be changed.  Click on the Referenced Libraries tab: this shows the layers  
you selected when you created the workspace. Recall that you selected the 
standard ADS layers when you created the workspace / library.  If you had a 
PDK, then its layers would appear here.  In the Referenced Libraries tab, 
notice the green checks.  This means your library has layout units, resolution, 
and schematic and layout layers defined.   

c. Click the button to Show Other Technology Tabs and then click the Layer 
Display Properties tab – this shows the properties of the drawing layers that 
were previously defined – these are the ADS built-in standard layers you 
selected when you created the workspace library.  In other words, your 
workspace library, My_Layout_lib, is referencing those layers for this design.  

 
 

d. Click on the button on the bottom to Add Layer / Display Properties. 
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e. When the dialog appears, type in the name to My_Metal as shown here.  The 
layer number is the next available number – in this example it is 39.  Also, 
change the color to a gold-like color.   Click the OK button at the bottom as 
needed to close the dialogs.  

 

 

f.  In the layout window, 
click Options > Layer 
Preferences. Notice 
that the Layer 
Preferences dialog now 
shows your new layer:  
My_Metal.  Click on it 
and it becomes the 
entry layer as shown 
here.   

g. Close this dialog (click 
the red X – Close button 
in the upper right 
corner. 
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h. In the layout window, click Options > Technology > Layer Definitions.  
When the dialog appears, click the button to 
Show Other Technology Tabs.  In the Layer 
Display Properties tab, scroll down, as shown 
here, to see your added layer (My_Metal). Now, 
you know that these library definitions for the 
layers are accessed from either the Main 
window or layout.  Look through the tabs for a 
moment and then close the dialog.   

 

4. Layout Preferences (Grid/Snap) 

a. In the layout window, click 
Options > Preferences. 

When the dialog appears, look 
through the tabs.  These apply to 
your workspace and you can save a 
copy of your preferences and use it 
in other workspaces.  

Notice the snap grid distance of 5 for 
both x and y. Also, you should have 
the Grid box checked for snapping – 
you can see this on the layout tool 
bar als0 – the Grid snap icon.. 

 

b. Cancel the dialog. 
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5. Drawing and Measuring 

a. On the layout tool bar,  the current entry layer 
should be My_Metal.  Change it as shown here if it 
is not.   Again, v = visible and s = selectable.  If you 
wanted to change these v and s  settings, you 
would Options >Layer Preferences but do not 
change them now. 

b. Click on the Insert Rectangle icon and it will 
attach to your cursor.  Then zoom in (use your 
mouse wheel or the icons) near the origin + on 
the grid – this is absolute (0,0) x,y.  

c.  Then draw a rectangle 5x50 mils, as shown 
here, which begins at absolute 5,5 and ends at 
55,10.  You can see the 
cursor see the cursor 
readouts on the layout grid 
and also at the bottom of 
the layout window.  
Because the snap grid 
preference is set to 5, this 
is easy.   

d. End the command using 
either your Esc key or the 
End Command icon 
shown here.   

e. Use the command, Insert 
Ruler and snap it to the 
grid below the below the 
rectangle – you can move 
it if needed after you insert 
it.  This is how the ruler 
works to measure shapes. 

 

f.  Select the ruler and delete it.  Now, use the 
command Insert > Measure and use this tool to 
measure the rectangle – try it diagonally also and 
use the Clear button.  When finished Cancel it. 
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g. Click on the upper left vertex of the rectangle and notice that the relative x-y 
value becomes zero.  Then move the cursor – this is another way to measure.  
With grid snap set, you should see it move in increments of 5 as shown here. 

Now, you have several ways to measure shapes and distances and the 
properties of a selected shape are also available at any time. Later on, you will 
use more information features like this Properties docking window.  

 

6. Default Stretching and Rotating and Moving 

a. Select the rectangle and notice try using the stretch and rotate handles to 
change the width, length, and rotation. Notice that you can only stretch or 
rotate in fixed increments with the grid snapping turned on. 

b. Turn off the Grid snapping by clicking the icon as shown here – it will not be 
active anymore.  Notice that you can now 
stretch the rectangle in small increments 
but it is not manageable.  Also, you still 
can only rotate it in 90 degree increments.  

c. Try moving the rectangle, it is not easily moved to 
a specific coordinate.  Next, you will see how to 
control these things easily.   
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d.  In your layout, turn the grid snapping back on. 

e. Use the Undo icon to return to the original rectangle 50x5 mil as shown here. 

 

7. Hot Key Setup 

a. Now it’s time to create a few Hot Keys for fast control of 
the layout preferences.  Click the command: Tools > Hot 
Key/Toolbar Configuration. 

 

b. In the dialog, assign the keyboard letter o for Options > Preferences as 
shown here.  Select the command and then type in the letter, click Assign, 
and then Apply.  Then try it – it should work. If not, redo it. 

Set these 3 keyboard hot keys:  Insert > Coordinate Entry = C, Options > 
Layer Preferences = L, Insert > Measure = M.   Be sure to click Assign and 
Apply each time.  Verify they work (try them) and click OK to close the dialog.  

Remember that there are default Hot Keys already set, such as Ctrl+R for 
rotate, so these are just some additional ones that will be used in this lab. 
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8. Grid Control and Viewing 

a.  Use your new Hot Key: O to 
open the Options 
>Preferences. When the 
dialog appears, click th e 
Grid/Snap tab.  Compare your 
grid to the one shown here.  
Zoom out as needed to verify 
the default grid spacing has 5 
minor grid dots between each 
major grid mark: + .    

b. Verify that the snap grid distance is 5 
units (mil)  and the there are 2 snap 
points between each Minor grid mark 
(equal to 5 mil each).   

c. Change the snap distance to 1 and the 
snap grid (minor) to 1 as shown here.  
Click OK – the dialog will disappear and 
the changes will take place.  Then 
verify that you can move the object in 1 
mil increments on those grid dots. 

d.  Right-click in an open area of layout and select Grid Spacing - notice you 
can also use the preset snap settings. Try some of them 
quickly. 

e. Finally, reset the grid spacing back to: 5 mils snapping 
distance with 5 snap points between each minor gird dot, and 
2 minor grid dots between each major grid mark.  These are 
the values you will use to continue. 

 
 

f. OPTONAL: Click the Fast Grid icon shown here 
and try it if you have it loaded.  Afterward, reset 
the grid spacing back to: 5 mils snapping 
distance with 5 snap points betwee each minor gird dot, 
and 2 minor grid dots between each major grid mark +, as 
shown here – type in the values or use the sliders. This 
makes grid modifcation fast and easy !. 

 
  



Lab 1: Layout Basics  

Copyright 2013 Agilent Technologies  

12 

9. Coordinate Entry 

a. Delete the exsiting rectangle so your layout 
is empty. 

b. Change the insert layer to cond and then 
click the Insert Rectangle icon. 

c. Use your hotkey: c.  This will open the 
coordinate entry dialog ready to draw the 
rectangle on the cond layer. Notice it is set 
to draw using Absolute values. 

 

 

d. Enter the values: 5 and 5 for 
the x,y coordinates of the 
first vertex point and click 
Apply.  Then move your 
cursor to the 5,5 absolute  
location and notice that it 
shows dx:0 and dy:0 – this 
is the starting point for the 
rectangle.  

 

 

e. Enter the second set of x,y 
values as 55 and 15 and click 
Apply.  The tool will now 
complete the drawing at that 
diagonal point as shown here.   

Notice that the dialog is still 
active for drawing rectangles. 
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Next, you will draw another rectangle (50x6) at 1 mil above the existing 
rectangle. Even though the grid is set, the rectangle can still be drawn without 
snapping to it - by using Coordinate Entry with the Snapping turned off as 
shown here.  Otherwise, you would have to change the grid snapping. 

f.  With rectangle and coordinate entry still active, enter the first coordinate at 
5,16 and click Apply.  Enter the next at 55, 21 and click Apply and OK to 
dismiss the dialog.  Use the End Command icon or Esc = rectangle ends. 

  

 

10. Properties and Info and Display Order 

a. Select the new rectangle.  In the Properties window change the layer to 
My_Metal and change the height to 10 as shown here.  Then click in an 
open area of the layout and it is done.  Now you have adjusted the size and 
layer without having to stretch it or use another command – this is fast and 
easy for all your artwork.  
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b. if the Info window is not open, click on an empty area of the toolbar as 
shown here and select Info.  Then click on the Shape: rectangle as shown 
here.  Immediately, that item is selected (highlighted) in layout so you can see 
it.  Like the Properties window, the Info window is called a docking window 
because it can be moved (docked) to other positions in the layout window 
frame or on your screen.  You try docking it to another position if desired. 

 

c. In the layout, move the My_Metal rectangle so it overlaps the cond rectangle.  
It is difficult to see, but cond appears on top because it is after My_Metal in 
the Display Order of the technology layer definitions.  You do not have to go to 
that dialog now, but you remember that the order can be changed. 
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11.  Navigator, Search and Layer Docking Windows 

a. Set the Entry layer to resi and draw a circle that 
covers the two rectangles, as shown here – it 
does not have to be exact.  Then end the 
command. 

b. If not opened already, click in an empty area of 
the toolbar and select the remaining three 
windows as shown here: Navigator, Search and Layers. 

c. Now you should see the Search window docked in the layout 
window usually in the lower right by default, and the Navigator 
window docked in the lower left.  Also, the Layers window will 
appear – all as shown here. As your designs get larger and more crowded, 
these become more valuable.  But try using them now to see how they 
operate, including the Options. You can open or close them at any time during 
the lab exercises. 

 

d. Use Ctrl-A to select everything in layout and then press the Delete key or 
use the Delete icon as shown here to clear the layout for the next steps. 
Also, close the docking windows for now. 
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12. Generate a Layout from Schematic 

a. Go to the Main window and add a schematic to the 
cell.   Click the schematic icon and Browse to cell_1 
(or type it in) and uncheck the box for the schematic 
wizard - click OK as shown here. 

b. When the schematic opens, select the palette: 
Lumped-With Artwork. 

This next step shows how schematic elements with 
artwork are generated.  Afterward, you will modify the 
generated layout as you might for board or IC design. Of course, PDKs will 
have their own components but this exercise is useful in that case also. 

c. In schematic, build this simple filter circuit, including the ground and two pins.  
Use the exact components shown here so that you get the correct layout. 

 

d. Use the schematic command: Layout > 
Generate /Update Layout.  When the 
dialog appears, click Sync only the 
section starting with and select P1 as 
shown here.  This is how you can 
specify where to start from left to right. 

e. Look over the dialog settings (keep the 
other defaults) and then click OK and 
the layout will be generated. 
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f. Next, you should see a status message about 
the layout generation. If there were any 
problems information would appear here. 
Otherwise, click OK.  If not, go back and check 
your work and repeat the steps if necessary. 

g.  Your layout should look like the one shown 
here. If so save it.  The next step editing these layout items and drawing some 
others, including traces. 

 

NOTE on ground 
symbols in layout: 

The ground symbol is not 
recommended for layouts 
and NOT used for EM 
simulation.    In general, 
they should be deleted. 

 

 

13. LVS (Layout vs Schematic) and Net Names 

a. In layout, move P1 away (to the left) of R1 and then 
delete the wire – notice that a dash-dot-dash line 
appears. This means the connection still exists in 
schematic. 

b. Go back to the schematic, and do the same: move 
P1 away from the resistor and delete the schematic 
wire as shown here. There is no dashed line because 
you deleted the wire in layout. 

  

c.  Go back to layout, and use the View All icon to 
refresh the screen.  You should see the dashed 
line has disappeared.  This is how ADS layout 
and schematic are synchronized. 

NOTE: Only schematic components with 
artwork work this way (synchronization). Next, 
it’s time to use the LVS feature. 
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d.  In layout, reconnect P1 to the resistor pin, on 
the pad, as shown here.  But do NOT reconnect 
it in schematic. 

e.  Also in layout, delete the ground symbol so 
your layout looks like the one shown here.   

 In layout, use the command:  Tools > ADS 
Desktop LVS.   When the dialog appears, 
check the box for Auto zoom and click the Run 
button at the bottom as shown here. 

 

f. The LVS dialog will 
show the errors – but 
you need to use your 
cursor to expand the 
Nodal Mismatches 
and then click on the 
errors.  As shown 
here ADS will 
highlight the 
component or layout 
item where the error 
occurs. 

g. Reconnect P1 in schematic - then save and close the schematic window.   

h. In Layout, use the command View > Navigator Window (same as right-
clicking toolbar).  When the Navigator appears, click on C1 – notice it is 
highlighted and also notice the properties shows the net names.  You can also 
click on a net name (navigator) and the connection will be highlighted – try it ! 
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14. Layer Preferences for Visibility 

a. In layout, select the capacitor and move (drag) it down 30 mils – notice the 
wire will stay attached to the pins.  Use your hotkey M to measure (verify) the 
distance.  Then change the entry (insert) layer to bond and draw a rectangle 
40x60 over the capacitor - it should snap to the grid as shown here.  

 

b. The bond layer rectangle is drawn on top of the cond C1, making it difficult to 
see.  Therefore, one way to make it easier to see is to change the layer 
preferences. Use your L hotkey to view the Layer Preferences.   

c. Select the bond 
rectangle you just 
inserted and change the 
following: 

Shape Display = Both 

Transparency = less 
Opaque. 

Select Pattern = box 
near corner as shown 
here (results in dots). 

C1 should now be more visible under the rectangle as shown here.  You can 
also change the display order in the technology layers or you can 
also turn visibility on or off as needed.    

NOTE:  Component and 
instance name visibility are 
on silk_screen layers in this 
library. Try it… 
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15. Modify, Edit, and Move Commands 

a. With nothing selected, click the Edit > Modify command and 
notice the choices.  Some of these are obvious, such as Force 
to Grid.  The Convert to Polygon command is for converting 
traces to polygons but not all other components. And the Join 
command is for polylines (not polygons). 

b. Select the bond rectangle that covers C1 and right-click.  
Select the command Modify > Split.  Look at the bottom left of 
the layout window – the message tells you to select a corner – 
click on the upper left vertex and then select the second corner 
as shown here at 40,-20 coordinates. You should now have two 
separate polygons.  

c. Move one of the polygons to verify that the split worked.  Then use the undo 
icon to move it back.  Now select both polygons and use the 
command: Edit > Merge> Union – this is how you can merge two 
polygons into one if they are on the same drawing layer. 
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d. Use the Undo icon to return the rectangle to its original shape.  Select the 
rectangle, right-click and use Modify > Explode.  Deselect the rectangle (click 
in an open area). Then move one of the lines as shown here – the rectangle is 
now a number of individual polylines.  

e. Use the Undo icon as needed (before the Explode) to reset the rectangle. 
Right-click the rectangle and use Modify > Break.  Select the rectangle 
outline and move it – it is now a closed polyline.   

f.  Use the Undo icon as needed to return the rectangle to its original place.   

g.  Right-click and use the command Modify > Chop.  Select the area shown 
here in the middle of the rectangle (40x20) so that the middle is chopped out.  
Now you have two rectangles – one under each pad (like a solder mask area).  
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h. Select the capacitor C1 and use the command Edit > 
Component > Flatten.  Then delete the wire that 
connected it to the resistor pad so that you have four 
polygons as shown here.  In general, wires are to be 
avoided in layout. 

i.   Rubber-band (select) the four 
polygons and use the command:  Edit 
Move > Move Relative.  Enter the 
values X=25 and Y= - 40 and click 
Apply and then Cancel.  This should 
move the polygons to the right 25 mils 
and down 40 mils as shown here. 

j.  Delete these layout components: L1, 
R2 and P2.  Then save the layout. 

 

16. Traces and Paths 

a.  Set the entry layer to My_Metal. 

 

b. Click on the Insert 
Trace icon and the 
dialog will appear. 

c.  Draw a mitered trace from the 
R1 pin (click on it) to the middle 
of the Cond rectangle as shown 
here.  To do this, you will need 
to click for the corner with the 
trace aligned vertically over the 
midpoint of the cond rectangle.  
To end the trace, use the Space 
Bar - it creates a pin on the end. 

If you make a mistake, delete it 
using your Ctrl key (if snapped 
to a pin) and try it again – it 
takes a little practice to use it efficiently. 



Lab 1: Layout Basics  

Copyright 2013 Agilent Technologies  

23 

d.  Close the Trace dialog when complete. 

e. Click on the Insert Path icon. When the dialog appears, set the corner type to 
Curve and draw a path (as shown here) starting at the cond rectangle, then 
down about 30 or 35 mils and then curving to the right.  Go about 100 mils 
along the X axis and curve up again to the same plane as R1 (155 mils up), 
and ending as shown here.  It does not have to be exact but you can use 
Insert > Dimension Line to help, as shown here and delete it afterward.   
Again, this takes a little practice… 

 

17. Copy Using Reference and Mirror About X or Y  

a. Select the path you just drew.  Then click the icon: Copy Using Reference 
Point. Then click on a point about 30 mils to the right as shown here – that is 
the starting point.  Move the copy as shown about 130 mils and click. It does 
not have to be exact – the idea is to learn how it works. 
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b. Select the copied path and the click the icon: Mirror About Y Axis.  Now, you 
must select a point for the mirroring – like a swivel point.  In this case, click on 
the center of the vertical path and it will swivel or mirror about that point. 

 

 

c. Now move (snap) the mirrored copy in place 
as shown here.  

NOTE: Traces connected to the pins on the 
same net require the Ctrl key to be deleted.  
Otherwise they only stretch. 

 

 

 

NOTE:  If desired, select both paths, and 
use the command: Edit > Merge > 
Union. This step is not required but this 
is how it would work.  Also, for most 
layouts with components, Traces are 
preferred instead of paths because you 
can connect the pins. 

d. Save all your work.    
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18. Vias, Layer Binding and Connectivity  

You will now draw a via to another layer and create port 2. 

a. Change the insert layer to Hole. Now,  Draw a circle at the end of the path, as 
shown here, with a radius of 5 mils. 

b. Change the insert layer to cond2 and draw a final rectangle, 90 x 20 mils, as 
shown here.  Also, insert a pin (P2) as shown here – also called a port.  
NOTE: For EM use,  layout pins can become edge or area pins (associated 
with a polygon or edge) using the command: Edit > Edge/Area Pin.  

c. Use the command Tools > Check Connectivity > Show Physical and Nodal 
Interconnect. Then click on the rectangle connected to P2 as shown here.  
Notice the highlighting that indicates the physical connection between the 
layers: cond2 and hole but not to My_Metal. 

d. Use the Esc key to end the command. 

e. In layout, use the command: Options > Technology > Layer Definitions.   

f.  In the Layers tab, look 
at the Binding column 
for the hole layer – 
move the panels with 
your cursor if 
necessary.  

Notice that cond and 
cond2 are bound to 
hole – and notice that 
you cannot change this 
(not active in the field) 
because it is in a 
referenced library. 
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If you copied the library, or had a custom library, you could use letters instead 
of layer names which is recommended. 

g. Scroll down to your added custom layer 39, My_Metal, and insert your cursor 
in the Binding column as shown here.  Because you added this layer to your 
workspace library, you can change the binding.  Go ahead and type in the 
layer names: hole  cond2  cond  - as shown here.  Click Apply and OK. 

h.  In your layout, use the command again: Tools > Check Connectivity > 
Show Physical and Nodal Interconnect.  

Now, you should see 
that the binding gives 
you a physical 
connection from P2 (on 
the cond2 layer), 
through the via hole 
and connects to layer 
39 (My_Metal) and 
finally ends at the small 
rectangle on the cond 
layer at the pad (shown 
by the arrow).   

i. Save all your work. 

 

IMPORTANT NOTE on Connectivity: The ADS connectivity engine has four different 
modes, including using flight lines if there was a corresponding schematic connection.  
You can also force net names for connectivity.  Go to the Knowledge Center and look 
for the e-Learning tutorial con connectivity to learn how to use this tool. 

 

The final step is to create a clearance next. 
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19. Create a clearance 

a. Change the insert layer to: Packages. 

 

b. Draw a rectangle surrounding the layout design similar to the one shown here. 
Remember that you can change the layer display shapes or colors as needed 
– use your L hotkey for Layers Preferences if needed. 

 

c. Use the command: Edit > Create Clearance.  When 
the dialog appears, select the rectangle you just drew 
o the packages layer, as shown here. Click OK.  
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d. In the Create Clearance dialog, select the 
layers you want the clearance around – 
use the button to move them to the 
Selected Clearance area as shown here: 
My_Metal, cond, cond2, and bond. 

e. Set Apply to: All Shapes and specify the 
clearance Value= 10. 

f. Click the Apply button and you will see 
the clearance.  Click OK when finished to 
dismiss the dialog. 

 

 

 

Your final design should look similar to the one shown here 

 

This final drawing represents many of the layout skills you have used in this 
exercise.  You can review the concepts and skills covered if you have time. 

g. Save the layout and close all the windows, except for the ADS Main window. 

 
END OF LAB EXERCISE. 

 


